QQ登录

只需一步,快速开始

登录 | 立即注册 | 找回密码

简单挂官网

 找回密码
 立即注册

QQ登录

只需一步,快速开始

查看: 11242|回复: 102

简单辅助教大家用易语言制作鼠标连点(自动点击)器

[复制链接]

该用户从未签到

62

主题

186

帖子

1617

积分

伴坛终老

Rank: 6Rank: 6

积分
1617
发表于 2015-7-12 23:43:14 | 显示全部楼层 |阅读模式
本帖最后由 传奇辅助免费版 于 2015-7-12 23:47 编辑

简单辅助论坛设置这个易语言模块也不是摆设,现在就跟大家分享下怎么制作简单的鼠标连点器,大家需要下载一个易语言软件最好是能编译的,下面就是基本的操作步骤,基本思路就是用时钟来控制点击频率,用单选框决定点击方式。

1.我们先做界面,修改窗口的标题,添加一个分组框,在分组框里添加四个单选框并修改单选框的标题,如图所示:


1.png                                   2.png
               
            

2.接着添加一个分组框,在分组框里添加一个编辑框和一个标签,标签修改为毫秒,再添加两个按钮,命名为启动、停止,如图所示:



3.png                                4.png             


3.添加一个时钟,这样界面就基本完成,下面再看代码部分


5.png


4.先看两个按键的代码,当按下“启动”时,给时钟的时钟周期赋值,这里就直接采用编辑框的内容;当按下“停止”时,时钟的时钟周期为零



6.png

5.时钟事件的代码,这里采用如果为何种点击方式,然后用“模拟鼠标点击 ()”方法,取鼠标的位置,并选择相对应的点击类型。

7.png


6.快捷热键的代码,这里要用到标签的反馈事件,先添加一个标签,将标签的可视设为假,添加两个程序集变量F1、F2,在窗口创建完毕下注册热键;

接着在标签的反馈事件下,添加代码,判断是否注册成功,并执行相关动作,值得注意的是这里都用参数一作为判断。


8.png      

9.png            

10.png



7.加上图标,版本号等,这个程序就已经完成了!


11.png



最终效果图:


1111.png



这样一个简单的鼠标连点器就制作好了,大家可以根据自己喜好进行美化处理。




传奇辅助免费版为大家无偿服务,而简单挂排在首位。
回复

使用道具 举报

  • TA的每日心情
    无聊
    7 小时前
  • 签到天数: 445 天

    [LV.9]以坛为家II

    5142

    主题

    32万

    帖子

    116万

    积分

    管理员

    Rank: 9Rank: 9Rank: 9

    积分
    1164637
    发表于 2015-8-13 00:20:59 | 显示全部楼层
    1. .版本 2
    2. .支持库 eAPI

    3. .子程序 鼠标连点

    4. 选择框1.选中 = 取反 (选择框1.选中)
    5. .如果 (选择框1.选中)
    6.     时钟_开始点击.时钟周期 = 到整数 (组合框1.内容)
    7.     编辑框_显示.内容 = “”
    8. .否则
    9.     时钟_开始点击.时钟周期 = 0
    10. .如果结束


    11. .子程序 _单选框1_被单击

    12. 单选框2.选中 = 假

    13. .子程序 _单选框2_被单击

    14. 单选框1.选中 = 假

    15. .子程序 _时钟_开始点击_周期事件

    16. 编辑框_显示.内容 = 到文本 (到数值 (编辑框_显示.内容) + 1)
    17. .如果真 (单选框1.选中 且 选择框1.选中)
    18.     模拟鼠标点击 (取鼠标水平位置 (), 取鼠标垂直位置 (), #接口常量.左键单击)
    19. .如果真结束

    20. .如果真 (单选框2.选中 且 选择框1.选中)
    21.     模拟鼠标点击 (取鼠标水平位置 (), 取鼠标垂直位置 (), #接口常量.右键单击)
    22. .如果真结束

    23. .如果真 (选择框2.选中 且 选择框1.选中 且 编辑框_显示.内容 = 组合框2.内容)
    24.     时钟_开始点击.时钟周期 = 0
    25.     编辑框_显示.内容 = “”
    26.     选择框1.选中 = 假
    复制代码
    附鼠标连点功能源码。界面请自行编辑

    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    无聊
    7 小时前
  • 签到天数: 445 天

    [LV.9]以坛为家II

    5142

    主题

    32万

    帖子

    116万

    积分

    管理员

    Rank: 9Rank: 9Rank: 9

    积分
    1164637
    发表于 2015-8-13 00:22:56 | 显示全部楼层
    其实只需要左键和右键的点击代码
    大家就可以写出来了。
    逻辑自己编写。
    鼠标左键点击代码:
    1. 模拟鼠标点击 (取鼠标水平位置 (), 取鼠标垂直位置 (), #接口常量.左键单击)
    复制代码

    鼠标右键点击代码:
    1. 模拟鼠标点击 (取鼠标水平位置 (), 取鼠标垂直位置 (), #接口常量.右键单击)
    复制代码

    当然还有其他的方法。请大家自行摸索,用其他E模块也可以实现的。
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    无聊
    7 小时前
  • 签到天数: 445 天

    [LV.9]以坛为家II

    5142

    主题

    32万

    帖子

    116万

    积分

    管理员

    Rank: 9Rank: 9Rank: 9

    积分
    1164637
    发表于 2016-9-20 21:42:29 | 显示全部楼层
    全员加速中tfboys
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    无聊
    7 小时前
  • 签到天数: 445 天

    [LV.9]以坛为家II

    5142

    主题

    32万

    帖子

    116万

    积分

    管理员

    Rank: 9Rank: 9Rank: 9

    积分
    1164637
    发表于 2016-9-20 21:42:34 | 显示全部楼层
    英雄联盟加速器
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    无聊
    7 小时前
  • 签到天数: 445 天

    [LV.9]以坛为家II

    5142

    主题

    32万

    帖子

    116万

    积分

    管理员

    Rank: 9Rank: 9Rank: 9

    积分
    1164637
    发表于 2016-9-21 10:50:34 | 显示全部楼层
    新破天一剑辅助
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    无聊
    7 小时前
  • 签到天数: 445 天

    [LV.9]以坛为家II

    5142

    主题

    32万

    帖子

    116万

    积分

    管理员

    Rank: 9Rank: 9Rank: 9

    积分
    1164637
    发表于 2016-9-21 18:33:51 | 显示全部楼层
    qq龙珠外挂
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    无聊
    7 小时前
  • 签到天数: 445 天

    [LV.9]以坛为家II

    5142

    主题

    32万

    帖子

    116万

    积分

    管理员

    Rank: 9Rank: 9Rank: 9

    积分
    1164637
    发表于 2016-9-22 09:53:24 | 显示全部楼层
    网易uu加速器
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    无聊
    7 小时前
  • 签到天数: 445 天

    [LV.9]以坛为家II

    5142

    主题

    32万

    帖子

    116万

    积分

    管理员

    Rank: 9Rank: 9Rank: 9

    积分
    1164637
    发表于 2016-9-22 22:16:28 | 显示全部楼层
    cf加速器
    回复

    使用道具 举报

  • TA的每日心情
    无聊
    7 小时前
  • 签到天数: 445 天

    [LV.9]以坛为家II

    5142

    主题

    32万

    帖子

    116万

    积分

    管理员

    Rank: 9Rank: 9Rank: 9

    积分
    1164637
    发表于 2016-9-23 14:12:13 | 显示全部楼层
    qq三国外挂
    回复 支持 反对

    使用道具 举报

    您需要登录后才可以回帖 登录 | 立即注册

    本版积分规则

    Archiver|手机版|小黑屋|简单挂论坛 ( 黔ICP备15002384号-2 )

    简单挂在线客服

    GMT+8, 2020-2-23 17:51

    快速回复 返回顶部 返回列表